I have a problem with my iFolder3 server. Which, is currently running on
an IBM server RAID 5 with 3HDD.

SUSE Linux Enterprise Server 9 (i586)
We have OES1, and iFolder 3.2.
Kernal: 2.6.5-7.244-default

I’m not an expert on linux, but I feel my problem is related to the
way my drives have been mounted. I can no longer log into iFolder, access
iManager – and I’m seeing lots of problems with apache. My
server has been working well for almost 18 months. And now since
Wednesday I've got problems!

When the server boots up, xWindows loads as normal, but as I move around
the interface I start to see various messages such as:

‘Will not save configuration’
‘Configuration file ****** not writable’.

I’ve been reading some TID’s on the internet which talk about
the system going into RO mode to protect itself. I’m assuming this
is what’s happened to me. But who knows?

If I enter the command ‘mount’, at a prompt, it lists all the
drives that are mounted the only one which is RO is my CDROM.

I found another TID which suggested giving the command:

Mount –o –rw,remount /

Which I believe should remount my drive as RW(Read/Write), but when I give
this command, all I get is an error:-

‘can’t read superblock’.

If I exit xWindows, to return to the command prompt. When I log in as
root, the message is displayed:

FATAL: cannot change permissions of TTY: Read-only file system.

So now I’m stuck with a server, that’s not working well at
all, and I’m looking for some advice, suggestions of where to go

Can you help.