Netware 6.5 SP6
ZEN 7 SP1 IR1 HP1 (and 2)

We have a new motherboard with a PCI-Express Realtek 8101E NIC.

This NIC is recognised by the r8169 driver but . . Booting will not complete. It end with a DHCP failure and then presents a menu where you have to load / unload modules, or select another location (CD/DVD) to get/put your image from.

Pressing Alt-F4 you get another screen that indicates the problem:
eth0: link down
Checking the led's, this seems correct.

I already tried forcing speed, duplex and autonegotiation settings in the driver, no dice.

To do further testing, I made a multi-boot installation in such a machine:
- Windows XP-Pro (32)
- Debian 4

The NIC only has this link down problem on SLED10SP1, Windows and Debian 4 work fine.

I tried compiling the latest drivers (several) from the realtek site. They all have this link down problem.

I exchanged some mails with the driver devellopers of this R8169 driver, and they told me that the SLED10SP1 kernel (the same as Zen 7 PXE boot kernel) misses some 38 kernel patches related to this driver.

- Does anyone have experiance with patching the ZEN PXE bootkernel
- Does anyone know when Novell will update this kernel
- Any other suggestions


Thomas Roes