Hi there,

In one of our trees we have the middle tier server running on a cluster where all machines (XP SP1) connect without the aid of the Novell client. Due to tragically small, pitiful WAN links upgrading the ZFD agent to a standard level is taking some time. We have a mixed environment of ZFD agent v6.5 SP1 and v7 SP1 IR1.

Now the problem we're having is with a recently upgraded application which distributes registry keys and files to the machine and shortcuts to the Quick Launch and Start menu of the purely local Guest profile.

The only changes to this application were:
  • adding a few registry keys

  • adding a few files

  • creating a few new directories

  • adding a new variable

  • and, of course, raising the version number

Thus, no actual distribution settings were changed. Now, the problem that has arisen is when the user logs on purely as Guest (that is to say using the Windows XP Guest account to log on locally without authenticating to the middle tier) there is now a 2nd icon in the Quick Launch bar.

Both icons point to the same exe file on the C:\ drive. The 1st is a shortcut pushed out when the application is distributed to the network users. The 2nd shortcut is the same NAL-distributed shortcut that should only be visible to network users. If I delete the NALcache then this 2nd icon no longer works but I need to delete the duplicate shortcut from C:\Documents and Settings\Guest\Application Data\Microsoft\Internet Explorer\Quick Launch.

However, when I log back onto the machine as network user and verify the application the 2nd icon reappears on the Quick Launch bar. I have also tried to delete the application with the ZENcleanup tool (deletes the registry info so that ZENworks thinks the application has not yet been inistalled) as well as the NALcache and all shortcuts in the Guest profile but a verify always returns the same result.

The application itself is associated with 3 objects:
  • 2 Install users where it is set to Force Cache so that the application is cached upon a rebuild of the machine.

  • the User container where is it set to appear in the Start menu and the Quick Launch bar.

Can anyone point me in the right direction as to why this is happening and what I can do about it?

Any help would be much appreciated.

Many Thanks