I have an lvm2 container I'm trying to get rid of. It is on a XEN
host, space set aside for a SLES guest. I could not boot the guest and
was using kpartx to export the volumes to device mapper so I could get
to the files, then I discovered that would not work properly with lvm2.

I tried removing the various container elements using both EVMS/YAST
and evmsgui. I made some progress, but I now have 200gb tied up with
error 8022 in EVMS/YAST. I have tried giving the Container another
small chunk of lvm space so I could take away the larger piece, didn't

lvs shows the Container and volumes, the volumes were previously only
mounted in the defunct guest, they are no longer in /dev/mapper

Using a Recursive delete in evmsgui for the problem container gives a
Device or resource busy when I save it.

I haven't been able to find out what error 8022 means, I could guess at
what Device or resource busy might mean but that doesn't help me. Any
help in sorting this out would be greatly appreciated.