Short Version:

Applications that are associated to workstations as force run (lights out distributed applications) are suddenly not working consistently. These applications do things like install our add-on applications that are not on the base image. This has been working flawlessly for years up until this weekend. The only thing (that I know of) that changed is that we did some e-Directory maintenance on Monday (2-18-08).


- We are using ZENworks 7 SP1 HP5 on our client PCs and on our servers.

- We are running Netware 6.5 SP 7. We do have SLES 10 OES2 servers in the tree but they are not hosting any ZENworks services at this time.

- This problem seems to only be occurring at one site. All of the objects for this site are located under an OU called "FES".

- If we associate an application to a user object (in any OU) vs. a workstation object (as force run or to show up on the NAL), it works fine. If we try and associate the application(s) to our workstation objects at FES (to show on the NAL or to force run), we get inconsistent results. Sometimes the object will show up on the NAL (or install when set to force run), other times it won't.

- When I run naldiag.exe on a workstation that is imported under the FES OU, I can see that workstation helper is in the connected state and that the workstation can see all of the applications that are associated to it. These applications show a filter of Passed (Visible). They just don't show up on the NAL (or install if set to force run).

Do you think it's possible that there are some rights that are not set correctly in the FES OU? I've looked at the workstation object's rights in eDirectory and compared them with other workstations that work correctly. I could not see a difference. Perhaps there is something I'm missing? Is there a chance that there could be replica/partition issues? Could I run something besides the standard dsrepair to fix something like this? If anyone needs any log files, let me know and I'll get them to you.