I'm hoping someone can help me get ifolder running. I've installed it on
a centos 5.1 machine. I'll describe what i did hopefully someone will have
an idea as to what the runtime error is.
I did as much via yum and rpm as possible. Some packages needed httpd,
httpd-devel, autoconf, automake, xsp, xsp-devel, and mono-devel. I also did
a yum groupinstall Mono which pulled in the mono core packages. Finally
For me after mod_mono was installed i confirmed my httpd configuration
was still good, it was, and restarted.
Download latest source tarball from ifolder web site, as of 2/25/08 it
was ifolder3-server-3.5.7039.1.
My next hurdle came when i extracted the tarball and ran ./autogen.sh it
indicated libflaim was not installed. I downloaded libflaim src.rpm
v4.9.989, recompiled the source rpms for centos and installed both libflaim
and libflaim-devel. This time when i ran autogen.sh it errored with the
error "can not find Makefile.in" After googling on this error and finding
hints such as install libstdc++ which i had along with libstdc++-devel i
installed libtool and compat-libstdc++-33 and again reran autogen.
This time i took fhs-compliant options found on the "Howto build Ifolder
for Fedora Core 4" page. My autogen command is:

../autogen.sh --prefix=/usr/ --with-simiasdatadir=/var/lib/simias --sysconfdir=/etc/simias
make install
Now i disabled SeLinux, actually it already was on my system, and
ensured port 80 and 443 were optn on the firewall.
Referencing the above howto fedora page helped with this, but some steps
were different to get ifolder working behind apache. What i did was this:

mkdir /var/www/.config
chown -R /var/www/.config

The rest of the permissions indicated on the page were correct.
Now hook simias and ifolder in to apache. The howto page says do:

sed -i
ln -s /etc/simias/simias/simias_server.conf /etc/httpd/conf.d/
ln -s /etc/simias/simias/ifolder_webaccess.conf /etc/httpd/conf.d/
ln -s /etc/simias/simias/ifolder_admin.conf /etc/httpd/conf.d/

File paths and locations under /etc/simias were different, so i did:
ln -s /etc/simias/simias/apache/default/simias_server.conf /etc/httpd/conf.d
ln -s /etc/simias/simias/apache/default/ifolder_webaccess.conf
ln -s /etc/simias/simias/apache/default/ifolder_admin.conf /etc/httpd/conf.d

go over the various conf files symlinked in, make sure their paths are
right, and run an apachectl -t to ensure the configuration is still good. So
start apache.
I checked all of apache's error and access.logs to ensure no apache
startup errors occurred. WHen i go to http://hostname.ext/ifolder or /admin
i get a page explaining that a runtime error has occurred. I know ifolder is
installed or i wouldn't even get that.
I hope this information is useful to someone, i'm sorry it's not in a
more complete fashion, i'm going off my notes. If there's interest i will
make it so. If anyone has any suggestions on my runtime errors or even how
to provide any additional information let me know.