Home

Results 1 to 6 of 6

Thread: Printing in GNOME on OES2 server

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Posts
    3

    Printing in GNOME on OES2 server

    Hello,

    I'm trying to set-up a network printer in GNOME for the root user on an OES2 server.
    Since I'm not familiar with Linux, I'm a little bit in the dark here.

    The iPrint part is working (tested from a workstation), but when I try to install an iPrint printer on the server it fails with the message "iPrint Lib - The administrator may not have assigned a driver or the server may not support printer/driver installation for this platform."
    Since I have added a Linux driver to the driver store I'm guessing it is the second part of the message.
    It might be that the root user is not part of the eDirectory?

    I then tried to get cups started. To prevent a conflict with iPrint I changed cups.conf to use port 632.
    This worked and I am able to add our network printer (same as the iPrint printer) a print a test page.

    However, when I try to add the printer using YAST Printer Configuration, the configuration tool freezes at 60% with the message Loading current settings...

    I found some threads telling to delete the /var/lib/YaST2/ppd_db.ycp file.
    This did not help. The driver database is rebuild, but then the Printer Configuration tools freezes again at 60%.

    The threads also said that an updated cups should be downgraded to the original version shipped with SLES 10.2.
    This didn't help either.

    By the way, when I use lp -dPRINTER (where PRINTER is the printername in the eDirectory) it does work.

    Any other tips or ideas?

    Kind regards,

    Maikel

  2. #2
    Automatic reply NNTP User

    Re: Printing in GNOME on OES2 server

    MaikelNoordeloos,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    Has your problem been resolved? If not, you might try one of the following options:

    - Visit http://support.novell.com and search the knowledgebase and/or check all
    the other self support options and support programs available.
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.novell.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://support.novell.com/forums/faq_general.html

    If this is a reply to a duplicate posting, please ignore and accept our apologies
    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your Novell Product Support Forums Team
    http://support.novell.com/forums/


  3. #3

    Re: Printing in GNOME on OES2 server

    On Tue, 26 Feb 2008 11:56:02 +0000, MaikelNoordeloos wrote:

    >
    > Hello,
    >
    > I'm trying to set-up a network printer in GNOME for the root user on an
    > OES2 server.
    > Since I'm not familiar with Linux, I'm a little bit in the dark here.
    >
    > The iPrint part is working (tested from a workstation), but when I try to
    > install an iPrint printer on the server it fails with the message "iPrint
    > Lib - The administrator may not have assigned a driver or the server may
    > not support printer/driver installation for this platform."


    Did you upload a linux driver to the driver store?

    --
    Mark Robinson
    Novell Volunteer SysOp
    www.nds8.co.uk
    One by one the penguins steal my sanity...


  4. #4
    Join Date
    Feb 2008
    Posts
    3

    Re: Printing in GNOME on OES2 server

    Hello Mark,

    Thanks for your suggestion.

    I did indeed installed a linux driver using iprntman.

    The driver is listed in the iPrint printer installation.

    The problem seems to be the GNOME printer configuration, not so much the iPrint.

  5. #5
    Anders Bengtsson NNTP User

    Re: Printing in GNOME on OES2 server

    Well, in Gnome you just enter the ipadress when creating printers. If you
    use iPrint client for linux, go to the servers URL/ipp and
    click the iPrint printer for installing it.

    "MaikelNoordeloos" <MaikelNoordeloos@no-mx.forums.novell.com> skrev i
    meddelandet news:MaikelNoordeloos.35qz4o@no-mx.forums.novell.com...
    >
    > Hello Mark,
    >
    > Thanks for your suggestion.
    >
    > I did indeed installed a linux driver using iprntman.
    >
    > The driver is listed in the iPrint printer installation.
    >
    > The problem seems to be the GNOME printer configuration, not so much
    > the iPrint.
    >
    >
    > --
    > MaikelNoordeloos
    > ------------------------------------------------------------------------
    > MaikelNoordeloos's Profile:
    > http://forums.novell.com/member.php?userid=5645
    > View this thread: http://forums.novell.com/showthread.php?t=313527
    >


  6. #6
    Join Date
    Feb 2008
    Posts
    3

    Re: Printing in GNOME on OES2 server

    Hello Anders,

    Thanks for your reply.

    However, as I stated in my original post, I get an error message when I try to install the iPrint printer.

    So, I'm still stuck with the problem.

    Kind regards,

    Maikel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •