I'm trying to upgrade a 10.0.1 primary server to 10.0.2 (this is a total
deployment of only one machine, the primary server, at this time) and having
no luck. The server is stuck at "Pending."

After some digging, I'm wondering if the agent on this machine is at issue.

I'm applying the update via Configuration/ System Updates.

- Action: Download Update works fine (10.0.2 appears "downloaded").
- Status Details/ Set update to authorized works fine.
- Status Details/ Apply Update to All Devices (bypassing staging) leaves the
one server in a "Pending" state. (I did not create staging groups because
they seem to be optional - and we have only this one machine to update at
this time.)

The server does show up in Devices/ Servers, but...
ZENworks Agent Status: Unable to connect through IP Address or Host Name

and even the simplest zac command fails...

# zac --help
Exception: Connection refused

I tried this update and saw no change in behavior:

This all makes me wonder if the agent is hosed on that machine. But I have
to admit to being unsure about the proper role of the agent on the primary
server itself - should it need one at all?

I'll stop here but include some additional info below and thank you all in
advance for any troubleshooting info,

- Andy

Troubleshooting via this document:
3156703&sliceId=SAL_Public&dialogID=58060454&state Id=0%200%2058068025

/var/opt/novell/log/zenworks/services-messages.log shows nothing about

There is some data in /var/opt/novell/zenworks/zmd/cache/ZenCache, but only
a total of about 24K.

SystemUpdate.log does not seem to exist on the box at all. SystemUpdate.ini
does not seem to exist either.

/var/opt/novell/zenworks/tmp/sutmp.0/SystemUpdate.ini seems to have
reference to 10.0.2 stuff, but mostly .MSIs and not .rpms as I would

Other details:

SUSE Linux Enterprise Server 10 SP1

# rpm -q novell-zenworks-core-server

Andy Smith-Petersen
System Administrator
IT Network Services
University of Southern Maine