we have zen 7 sp1 ir1 running on Netware 6.5 sp6,
Laptops are mostly Dells latitudes using Middle tier with no client32
the older laptops worked fine..login to PC using wireless , wireless connects Nals runs fine.
Newer Laptops dell D820 and D830s, login to PC wireless seems to takes longer to connect, Nal is done refreshing before wireless has fully connected..
Workstation Helper says it connected but User is disconnected , icon in tray shows disconnected , if I refresh it stays offline, I can manually click the "zenworks Middle tier server login" option and it logs in fine.
new laptops are using Intel PROSet/wireless software

I have seen some similar posts but still wondering the best way to resolve this

stuff I have tried so far:
I have changed the shortcut in the startup to "C:\Program Files\Novell\ZENworks\NalView.exe /ns /time=30"
Nal waits 30 sec before starting, wireless is fully connected before the Nals starts refreshing.. Icon in lower right shows like its connected now , but user is still in a disconnected state..

Started looking into the "attempt to go online during refresh" in conjuction with the 30 sec delay but wonder what the possible downside of that could be..

any other ideas???
thanks in advance