I thought I would post this tidbit about the new Image Explorer. With ZCM10, I guess it is expected that you'll only browse created images on the server itself. This is silly, as I need to work on images on my workstation. Here's how I was able to get it working (on my Windows XP machine):

1) Install (or verify) Java RE 5.0 Update 11 or greater. Verify this by opening a command prompt (any location) and typing in "java -version". Java should report its version back to you.

2) Obtain novell-zenworks-zmgexplorer- from http://SERVERNAME/zenworks-setup/?pageId=imaging where SERVERNAME is the hostname or IP address of your server.

3) Install novell-zenworks-zmgexplorer- There will be a progress bar but no notification once the install is complete.

4) Verify the MSI installed correctly by browsing to %SYSTEMDRIVE%\Novell\ZENworks\lib\. There should be 4 DLL files and a subfolder called java that contains two JAR files.

5) Move the 4 DLL files into the java subfolder.

6) Browse to your Java folder. On my machine, it's %ProgramFiles%\Java\jre1.6.0_05\bin. Create a shortcut to javaw.exe.

7) Modify the shortcut:

a. Add " -jar zmgexp.jar" to the end of the target. For example:

Target: "C:\Program Files\Java\jre1.6.0_05\bin\javaw.exe" -jar zmgexp.jar

b. Replace "Start in:" with %SYSTEMDRIVE%\Novell\ZENworks\lib\java. For example:

Start in: C:\Novell\ZENworks\lib\java

Image Explorer should now start ok. Enjoy!


Jason K.


Unsolicited opinion: Weak Novell, weak. On the install DVD under \ZCM10_0_1.iso\Disk1\InstData\msi\ there's an MSI called novell-zenworks-jdk-1.5.0_11.msi that will provide the necessary java files that the normal batch file desires under %SYSTEMDRIVE%\Novell\ZENworks\share, but it still fails. This is because neither MSI sets the environment variable %ZENWORKS_HOME%. Why even bother providing the zmgexplorer MSI on the server under /zenworks-setup/ if it doesn't work (out of the box) on a workstation?