I have a Netware 6 SP3, edir 8.7.1, 3.7.2 Border Manager server which abends regularly and needs rebooted

I know the servers days are numbered however until the server is replaced I would like to try and resolve the abends.

I know installing the latest SP's would probably go a long way to resolving the issues I am having so....

I plan to install SP5 for Netware 6.0, are there any compatibilty issues with BM 3.7.2 and Netware 6.0 SP5??

Is there a higher service pack level available for BM 3.7,other than SP2??