Hi,

I try to migrate a DNS/DHCP service from Netware to Linux but there is something I'm doing wrong... maybe... somewhere...

Here what I do:

1) Netware server + eDir + DHCP/DNS running OK
2) Install SLES10sp1 on the linux box
3) Install OES2 :
- integration into current eDIR OK
- then the DNS installation fail at some point:

2008-03-20 16:33:26 <1> linux01(5097) [YCP] NovellDns.ycp:413 novelldns.write:Executing /opt/novell/named/bin/dns-inst 172.16.7.11 636 'cn=admin,o=cdp' '---'
'cn=admin,o=cdp' '---' 'o=cdp' 'o=cdp' 'o=cdp' 'o=cdp' 1
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Creating Group Object..........
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 DNS group object Already Exists :cn=DNSDHCP-GROUP,o=cdp
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Successfully created Group Object:cn=DNSDHCP-GROUP,o=cdp
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Creating RootServerInfo Zone ..........
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 DNS RootServerInfo Object Already Exists :cn=RootServerInfo,o=cdp
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Successfully Created/Modified RootServerInfo Object:cn=RootServerInfo,o=cdp
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 CreateRootRRs db_load error:-1001
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Adding DNS RootServerInfo RR objects failed error_code:-1001:error_message: U
nknown error cn=RootServerInfo,o=cdp
2008-03-20 16:33:27 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 DNS config failed to add/modify RootServerInfoObject....retcode:-1001
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 DNS RootServerInfo Object Already Exists :cn=RootServerInfo,o=cdp
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Successfully Created/Modified RootServerInfo Object:cn=RootServerInfo,o=cdp
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 CreateRootRRs db_load error:-1001
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78
2008-03-20 16:33:28 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 Adding DNS RootServerInfo RR objects failed error_code:-1001:error_message: U
nknown error cn=RootServerInfo,o=cdp
2008-03-20 16:33:29 <3> linux01(5097) [bash] ShellCommand.cc(shellcommand):78 timediff:1






It seems quite obvious to me that the objects already exists in the directory since a DNS server is already running on the netware server. Trying to start the named daemon anyway leads to:

20-Mar-2008 12:06:36.742 general: main: notice: starting BIND 9.3.2 -u named
20-Mar-2008 12:06:36.844 general: dns/db: critical: Unable to read locator reference from NCP server
20-Mar-2008 12:06:36.845 general: dns/db: critical: Failed to load RRs of a zone with error -10
20-Mar-2008 12:06:36.845 general: dns/hints: warning: Loading Root data from directory Failed
20-Mar-2008 12:06:36.869 general: dns/db: critical: Unable to read locator reference from NCP server
20-Mar-2008 12:06:36.870 general: dns/db: info: Unable to get configuration from eDirectory failed with error 25'
20-Mar-2008 12:06:36.870 general: server: info: loading configuration from '/etc/opt/novell/named/named.conf'
20-Mar-2008 12:06:36.870 config: isccfg/parser: error: none:0: open: /etc/opt/novell/named/named.conf: file not found
20-Mar-2008 12:06:36.914 general: server: critical: loading configuration: file not found
20-Mar-2008 12:06:36.914 general: server: critical: exiting (due to fatal error)
20-Mar-2008 16:14:21.004 general: main: notice: starting BIND 9.3.2 -u named
20-Mar-2008 16:14:21.437 general: dns/db: critical: Unable to read locator reference from NCP server
20-Mar-2008 16:14:21.441 general: dns/db: critical: Failed to load RRs of a zone with error -10
20-Mar-2008 16:14:21.441 general: dns/hints: warning: Loading Root data from directory Failed



What I would like to be able to do is to migrate this service from Netware to Linux... Any clue?

Many thanks

Olivier