I noticed the following errors in zmd-messages.log today after realizing policies were not being applied to the device. Running SLES 10 SP1 x86_64 with OES2. ZLM agent is 7.2.1 HP3.

Cannot find any info on this error. Any help would be appreciated.

24 Mar 2008 14:35:08 DEBUG PolicyManager Refreshing all of the policy data from https://zlm.mydomain.com/zenworks-policylookup/Polic
yLookup
System.DllNotFoundException: librpm
at (wrapper managed-to-native) Novell.Zenworks.Policy.Requirements.Requirement:rp mvercmp (string,string)
at Novell.Zenworks.Policy.Requirements.Requirement.Ve rcmp (System.String a, System.String b) [0x00000]
at Novell.Zenworks.Policy.Requirements.RpmRequirement .Check () [0x00000]
at Novell.Zenworks.Policy.Requirements.Requirement.Ev aluateRequirements (IList list) [0x00000]
at Novell.Zenworks.Policy.Requirements.RequirementGro up.Check () [0x00000]
at Novell.Zenworks.Policy.Requirements.Requirement.Ev aluateRequirements (IList list) [0x00000]
at Novell.Zenworks.Policy.Requirements.Requirements.P rocessList (IList list) [0x00000]
at Novell.Zenworks.Policy.Requirements.Requirements.P rocess (System.String xml) [0x00000]
at Novell.Zenworks.PolicyManager.PolicyManager.Evalua teSystemRequirements (PolicyManager.Client.PolicyRefreshResponseEffecti vePolicies[]
allEffPolicies) [0x00000]
at Novell.Zenworks.PolicyManager.PolicyManager.ParseG etEffectivePoliciesRPCReturn (PolicyManager.Client.PolicyRefreshResponseEffecti vePol
icies[] allEffPolicies) [0x00000]
at Novell.Zenworks.PolicyManager.PolicyManager.Refres hCachesFromPolicyLookupService () [0x00000]
at Novell.Zenworks.PolicyManager.PolicyManager.Refres h () [0x00000]
24 Mar 2008 14:35:08 INFO Progress Progress.Stop Message: Failed to refresh policies
24 Mar 2008 14:35:08 INFO Progress Is Stopped value: False
24 Mar 2008 14:35:08 INFO Progress Progress.Stop Message: Failed to refresh policies
24 Mar 2008 14:35:08 INFO Progress Is Stopped value: False
24 Mar 2008 14:35:08 ERROR ServiceManager Service refresh failed for 'ZENworks Linux Management': Failed to refresh policies

Thanks,
Dan