Today one of the eva's on our SAN caused one of five resources to go

The logger screen showed:

Deactivating pool "Shared"...
Dismounting Volume Shared

April 30, 2008 9:17:50 am NSS<COMN>-3.25-XXXX: comnPool.c[2672]
Pool Shared: System data I/O error 20203(zio.c[554]).
Block 149000603(file block -149000603)(ZID 63039119)

Go an error from free tree. Potentially lost 10 blocks

April 30, 2008 9:17:51 am NSS<ZLSS>-3.25-1449: zfsVolumeData.c[212]
Error reading VolumeData Block 104852497

April 30, 2008 9:17:51 am NSS <ZLSS>-3.25-1449: zlssLogicalVolume.c[4948]
Error reading PoolData Block 52426502, status=20206.

April 30, 2008 9:17:52 am NSS<ZLSS>-3.25-1457: zfsSuperBlk.c[1133]
Unable to correct super block header 3 (550491137) (Error: 4294967295).
Run verify.

Apr 30, 2008 9:27:43 am NSS<COMN>-3.25-XXXX: comnPool.c[2672]
Pool SHARED: System data I/O error 20203(zio.c[554]).
Block 106005982(file block -106005982)(ZID 2194)

Apr 30, 2008 9:27:43 am NSS<ZLSS>-3.25-1456: zlog.c[4029]
**system verification failed.
You may have to rebuild your volume. If this happens again, contact your
Novell Technical Support Provider.


The errors go on for a bit with variation on the block number.

I tried offlining and onlining the resource, but it failed saying
"Volume Shared could NOT be mounted. Some or all volume segments cannot
be located. If this is an NSS Volume, the pool may need to be activated
using the command nss/poolactivate=poolname". When I tried to run that
command I would get "Error 20203, blah blah state change unsuccessful"
and "Cluster-<FATAL>-<12022>:CVSbind Error 2"

I eventually was able to migrate the resource successfully to another
node(1) after I rebooted node(1) as I received a fatal error when trying
to "View Subsystems" through Secure Path client v 3.0.

A glimpse of one of four LUN's of the faulting resource in Secure Path
shows the following configuration;

Subsystem ID: 50001fe1500420b0
Chasis Name: <unnamed>
Load Distribution: Disabled
Path Verification: enabled
Auto Failback: enabled

Physical Path: 1-1-0-5
Through Controller: P5849D5AAPD049
Mode: preferred
state: active owned

Physical Path: 1-1-1-5
Through controller: P5849D5AAP9036
Mode: alternate
state: standby

Volume Label: <no volume labels>

**I can't find a single LUN identifier in Secure Path w/ a
"Volume Label: Shared"**

I am extremely concerned that Netware was not as graceful as SUN,
VMWare, and clustered Microsoft services. The others merely logged the
errors and changed their path to the other eva controller. Where should
I be looking for the cause of this problem? How can I fix it? Is there
anything that I need to do to verify the information is okay?

I really appreciate everyone's help. Thanks in advance to all those
that can help me as quickly as possible.