Apple Quicktime requires Windows XP or Vista.
Bummer. No new version of 7.X for W2k.
Guess I'll take the Secunia suggestion:

'The only available option for you to ensure that you are secure against
vulnerabilities in Quicktime 7.x is to uninstall the program from your
computer, and use an alternative media player.'

I don't use Quicktime much anyway since I mostly use Linux.

Thanks Apple, one less Windows app to maintain! w00t!