Been going around with Novell, including the development team all day yesterday. Apparently, SP2 for SLES10 is out and one of the base patches is a SLES10-ZYPP patch.

This patch WILL BREAK the ZENworks Management Daemon.

This patch WILL BREAK rug.

This patch WILL BREAK Novell Customer Center Configuration.

Apply this patch and you WILL NOT be able to register your SLES/OES2 server. Apply this patch and you WILL NOT be able to register catalogs with rug. Apply this patch and you WILL NOT be able to download/install any other patches using ZEN-Updater.

This patch WILL REMOVE your catalogs that were installed after you registered.

I've rebuilt my server twice already because of it. Had to yank zypper off the server and reinstall from the SP1 source to get it working again.

Here is my Novell Service Request to prove it:

10399194575