How may we install iFolder3.4 for sled10 sp2? I keep getting missing dependancies for mono and others as well, but when you download and try to install these they error out saying that other apps need these versions and won't work without them do you want to uninstall?

sp2 includes mono 2 and iFolder3.4 wants version 1.4 or higher, what the heck???