Hi all....problems with iFolder 3.6 on OES2 Linux:

after reconfiguring ifolder with the DNS name instead of the internal IP address to be able to get it to work behind NAT, now I cannot access iFolder web client nor web admin, even though the win32 client access works.

When logging from web client, it gives the following error:

Code:
Exception Message: System.NullReferenceException-Object reference not set to an instance of an object
Exception Type: System.Web.Services.Protocols.SoapException
Exception Site: System.Object[] ReceiveResponse(System.Net.WebResponse, System.Web.Services.Protocols.SoapClientMessage, System.Web.Services.Protocols.SoapExtension[])
Exception Source: System.Web.Services

Exception Stack:

System.Web.Services.Protocols.SoapException: System.NullReferenceException-Object reference not set to an instance of an object
  at System.Web.Services.Protocols.SoapHttpClientProtocol.ReceiveResponse (System.Net.WebResponse response, System.Web.Services.Protocols.SoapClientMessage message, System.Web.Services.Protocols.SoapExtension[] extensions) [0x00000] 
  at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke (System.String method_name, System.Object[] parameters) [0x00000] 
  at iFolderWeb.GetHomeServer () [0x00000] 
  at (wrapper remoting-invoke-with-check) iFolderWeb:GetHomeServer ()
  at Novell.iFolderApp.Web.Login.DoLogin (System.String username, System.String password, Boolean check) [0x00000] 

Username: TEC_PC0
User Full Name:  Utente Ufficio Tecnico

System iFolder Name: iFolder
System iFolder Version: 1.0.0.0
when loggin from web admin, it returns "Your session has been closed. Please log in. "

I even tried to re-configure and go back to the original config by entering the IP addresses of the server but it still won't work.

I've done some basic troubleshooting and the http://x.x.x.x/simias10/Simias.asmx works fine, ldap is fine, already deleted the wwwrun-temp-aspnet-0 and /tmp/.wapi directories.
When I login, the last thing that the simias log shows before the error is the following:

Code:
"2008-05-29 23:59:22,907 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetHomeServer"
where on a working server I would normally be getting

Code:
2008-05-29 23:59:22,907 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetHomeServer
2008-05-29 23:59:22,921 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - AUTHENTICATED USER
2008-05-29 23:59:22,921 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetSetting
2008-05-29 23:59:22,987 [-1272570976] DEBUG Simias.Security.Web.AuthenticationModule - AUTHENTICATED USER
2008-05-29 23:59:22,987 [-1272570976] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetiFoldersBySearch
2008-05-29 23:59:23,000 [-1279497312] DEBUG Simias.Security.Web.AuthenticationModule - AUTHENTICATED USER
2008-05-29 23:59:23,000 [-1279497312] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetiFolder
2008-05-29 23:59:23,016 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - AUTHENTICATED USER
2008-05-29 23:59:23,016 [-1225577568] DEBUG Simias.Security.Web.AuthenticationModule - The web method is: GetAuthenticatedUserPolicy


Has anybody ran into this before?

Thanks,

Giordano