Home

Results 1 to 4 of 4

Thread: iManager "Header" Presentation, Tomcat 4 or 5

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Posts
    125

    iManager "Header" Presentation, Tomcat 4 or 5

    Good Morning,

    Ever since updating to OES Netware 6.5 sp7 (only one of my server out of 15), the "header" gif images do not show on any iManager web page.

    iManager still works, and everything below the header shows correctly no matter what Role or Task I choose.

    The single gif at the top of the Roles and Tasks colume that says "Roles and Tasks does show, and it is in the same location as the other gif's that don't show.

    The other strage thing is that I have a tomcat "5" directory as well as a "5.0" directory. My autoexec.ncf points to the 5.0 directory though. Not to mention the "4" directory.

    I'm thinking this may be some type of a permissions error, but I don't know where to trace it.

    Thank you,

    Tony

  2. #2
    Join Date
    Aug 2007
    Location
    Luxembourg
    Posts
    5,142

    Re: iManager "Header" Presentation, Tomcat 4 or 5

    You have the "typical" SP7 upgrade problem caused by having used tomcat5
    before SP7. In previous support packs, tomcat5 was included with NetWare
    6.5 but not used by any Novell programs. Unfortunately, in SP7, when
    Novell switched to using tomcat5 for iManager 2.7 they also switched to a
    new directory naming for tomcat5. The "old" tomcat5 was int he directory
    sys:tomcat\5\ while the new one is in syS:\tomcat\5.0\
    If you have a "normal" NetWare 6.5 installation only using tomcat4, then
    SP7 will correctly install tomcat5 and configure Apache to use tomcat5 for
    iManager. If you however had been using tomcat5 before, then the SP7 will
    fail to correctly configure apache to use the correct tomcat5 for iManager
    and your iManager installation will not work.
    To solve your problem, please post your httpd.conf file found in
    sys:apache2\conf and we will tell you what modifications you need to make
    to that file the fix your configuration.

    --
    Marcel Cox
    http://support.novell.com/forums
    ------------------------------------------------------------------------
    Marcel Cox's Profile: http://forums.novell.com/member.php?userid=8

  3. #3
    Join Date
    Feb 2008
    Posts
    125

    Re: iManager "Header" Presentation, Tomcat 4 or 5

    Thank you Marcel.

    That was enough information for me to get it fixed. I just had to remove the old imanager configuration line from the httpd.conf file:

    # Include sys:/tomcat/4/conf/nps-Apache.conf

    The new line pointing to the 5.0 directory was in place below that.

    Would you say it was safe to remove the tomcat "5" directory (not the 5.0 directory) that I assume was put in on the sp7 install ?

    Thank you again for the help,

    Tony

  4. #4
    Join Date
    Aug 2007
    Location
    Luxembourg
    Posts
    5,142

    Re: iManager "Header" Presentation, Tomcat 4 or 5

    afiore wrote:

    >Would you say it was safe to remove the tomcat "5" directory


    Proivded you did not use it for any of your own web applications, you can
    safely remove the "5" directory as no Novell product has officially used it.

    --
    Marcel Cox
    http://support.novell.com/forums
    ------------------------------------------------------------------------
    Marcel Cox's Profile: http://forums.novell.com/member.php?userid=8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •