here is the event log entry

Faulting application explorer.exe, version 6.0.3790.3959, stamp 45d6a1b7, faulting module nalshell.dll, version, stamp 46f14b2f, debug? 0, fault address 0x00024eb8.

The nalshell.dll is version 10.0.3 on my workstation, But is 10.0.1 on the server! Is this ok? do I have a bad upgrade to 10.0.3 on the server?