When I try to install Squid 2.6.STABLE6-0.10.i586.rpm it fails due to a dependency with libdb-4.4.so. My system has db-4.3.29-15.2. When I run Auto Update 4.4 is not available. I downloaded db-4.4.20-16.i586.rpm and when I try to install it I get the following message.

file /usr/lib/libdb-4.so from install of db-4.4.20-16 conflicts with file from package db-4.3.29-15.2
file /usr/lib/libdb_cxx-4.so from install of db-4.4.20-16 conflicts with file from package db-4.3.29-15.2

I am not sure what needs to be done to upgrade from Squid 2.5 to 2.6. I do not want to cause any issue with these other libraries and how they may interact with other systems.

Is anyone running Squid 2.6 on SLES 10.2 using NTLM authentication? If so, how did you do the upgrade/install?

Thank you for any help,
Mark