I couldn't help but notice that after a fresh install of OES2 Linux, it
seems that tomcat5 is not used for iManager and things?

At least a:

/etc/init.d/tomcat5 status

shows not used

It's been my experience that tomcat5 seems faster than tomcat4, so I was
wondering about this (on NetWare, when you upgrade to SP7 and imanager
2.7, it installs Tomcat5 and seems to be used by iManager, etc.)