Getting this message right after installing the Adaptive Agent on new machines.

Running ZCM 10.0.3 (linux server)
Windows XP SP2 (workstations)

Anybody else getting this? Is there a way to fix it?

I am patched all the way to SP2 on XP, so I can't imagine it is a hot fix.

Please god don't tell me I have to upgrade to service pack 3 for XP.

Thank you in advance.