I am trying to configure an XP group policy using a computer running XP SP3. When I click the Configure button to edit the policy, I get a "Hotfix required" message "To operate on security settings, Windows XP Hotfix KB897327 is required." I am unable to edit or import security settings without it.

I downloaded the hotfix, but, when I tried to install it, I get a "KB897327 Setup Error" message stating "Setup has detected that the Service Pack version of this system is newer than the update you are applying. There is no need to install this update"

Is this a known bug?