-Zen 7 Agent running on XP Pro SP2, Server Running on Netware 6.5 SP 7
-Workstation Policy is associated to workstations and set to apply at startup
-Workstation Policy package has both user and computer settings modified
-Initial logins are being performed with standard user accounts (not admins)


I am seeing on occasion where it appears the the Windows Firewall portion of the local GPO is active yet when I go into the properties of My Network Places, the connections do not indicate "connected, firewalled", but rather just "connected". Yet when I open gpedit while logged in as the user (using the local admin account and Runas), I can see that the policy took. Settings are visible in both the Domain and Standard profiles. In fact, if I open the Windows Firewall settings from Control Panel, the Firewall is grayed out as it should be, and I can see my exceptions in there. There doesn't seem to be any pattern to why this happens. I've had instances where it correctly indicates that the connections are firewalled and other times not. I checked C:\windows\system32\grouppolicy directory and all the latest files are there. I open registry.pol and I see the proper firewall settings. Then I thought that maybe the policy on the workstation got corrupt, so I deleted all three group policy directories in system32, rebooted a few times, and same result. I even tried dropping a fresh XP image on the machine and it still did the same thing. As a last resort, I logged in using an admin account and voila, I see that my connections are now "firewalled" in My Network Places properties. Log back out and then back in as the standard user, and it still shows "firewalled".

Do you think this is just a quirk of LGPO firewall settings and only cosmetic? Like I said, I've had instances where it works fine but other times it does not. The fact that logging in with the admin account makes it visible indicates to me that either those permissions were needed or just the fact that another user logged it forced it to properly update.