There was a recent patch for the novell client which replaces the file nicm.sys due to a security vulnerability. When I install this patch onto servers which have the Zenworks Middle Tier software installed it prevents the client machines from authenticating to edirectory via the middle tier servers.

Once I put the old vulnerable nicm.sys file back then the authentication begins working again.

I've had dig around to see if any one else is experiencing this problem but I haven't found anything.

Any suggestions on how I might fix this. I would ideally like to resolve this as I don't like my servers being vulnerable.

Thanks in advanced