BES 4.1.4 not connecting to GW 7.0.3 BES Address book will not sync with GroupWise System Address book. Cannot find GW user in BES Manager.

I tried so many things. I continued getting those " Err=Directory Services Data missing " errors. (See Error Symptoms below)

While I was installing win 2003 on another machine to create a whole new BES srv from scratch, I tried 1 last thing. I created a new GW Trusted App and put the new KEY into BES. But this time, I ran the Key Generation program from my XP machine instead of running it right on the BES server. I noticed that the APP NAME in the BES Config Server (on the GroupWise Settings Tab where the Key is located) did not match with the Name for my new GW Trusted App (as seen in ConsoleOne). So I changed it in BES to match what was in GroupWise. WHAM/BAM-- BES started talking to GW instantly!

I believe it was the NAME that caused all my problems. I don't believe that generating a trusted Key from my xp machine instead of a win 2003 srv would make a diff. I don't think it was a new Key that did the trick, I had tried a new key once before.

My efforts to reproduce the problem by simply changing the App NAME in BES server Config have failed so far; HOld on... its confirmed I broke it again! The BES logs did not start reporting errors until I had completely rebooted the server. The POA logs did show the errors right after I changed the NAME. That's weird. All 3 log files now show the original errors again (see below) I reset the NAME in BES Config back again so it matches GW. It works AGAIN!

BES server has GW 7.03 client installed
Novell GW server is 7.03
In GW Server, the trusted Application Name = RIM BES (default name from the Generation program)
BES server config = App name = BES

BES's ADMIN_GWCO log file:
[34157] (07/16 19:18:11):{0x1E60} {GWCO} {GWConnector} Novell GroupWiseObject Library: C:\Novell\GroupWise\\gwcma1.dll, Version: 7.0.3
[34493] (07/16 19:18:11):{0x1E60} {GWCO} {GWConnector} GWConnector Version:
[34481] (07/16 19:18:11):{0x1E60} {GWCO} {GWConnector} GW API Mode=GW_SOAP
[34154] (07/16 19:18:11):{0x1E60} {GWCO} {GWConnector} Mailstore test start, test level=1
[34116] (07/16 19:18:12):{0x1E60} {GWCO} {srv-bes} Login: Start
[14123] (07/16 19:18:12):{0x1E60} {GWCO} {} MultiLogin failed, error=System.Runtime.InteropServices.COMException (0x80004005): Login unsuccessful
at System.RuntimeType.ForwardCallToInvokeMember(Strin g memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at GroupwareTypeLibrary.DIGWSession4.MultiLogin(Strin g vUserID, Object vCommandLine, Object vPassword, Object vWhenToPrompt, Object vReserved)
at ConnectorLibrary.ICEWrapper.AccountLogin(String& sUserID, String& sDomain, String& sPOA, String& sFID3)
[14047] (07/16 19:18:12):{0x1E60} {GWCO} {srv-bes} Login Failed, Username=srv-bes
[34045] (07/16 19:18:12):{0x1E60} {GWCO} {srv-bes} Logout admin user
[14095] (07/16 19:18:12):{0x1E60} {GWCO} {GWConnector} Mailstore test failed

BES's ADMIN_GWSC log file:
[34480] (07/16 19:18:11):{0x1EA0} {GWSC} {GWSoapConnector} GW API Mode=GW_SOAP
[34480] (07/16 19:18:11):{0x1EA0} {GWSC} {GWSoapConnector} SSL=OPTIONAL
[34483] (07/16 19:18:11):{0x183C} {BESMgmt} {GWSoapConnector} Begin BESMgmt Thread
[34154] (07/16 19:18:11):{0x1EA0} {GWSC} {GWSoapConnector} Mailstore test start, test level=1
[34116] (07/16 19:18:11):{0x1EA0} {GWSC} {srv-bes} Login: Start
[14047] (07/16 19:18:15):{0x1EA0} {GWSC} {srv-bes} Login Failed: Err=Directory Services Data missing, UserName=srv-bes
[34045] (07/16 19:18:15):{0x1EA0} {GWSC} {srv-bes} Logout admin user
[14095] (07/16 19:18:15):{0x1EA0} {GWSC} {GWSoapConnector} Mailstore test failed

GroupWise's POA log file (verbose mode)
19:18:11 343 C/S Login Windows ::GW Id=srv-bes :: Trusted App=BES
19:18:12 343 Error: Directory Services Data missing [D105] User:srv-bes App( BES )