Thanks to Gregg Nicholas for spotting the critical point on this
issue... He saved me from putting an embarrassing security hole in our

Thanks to Paula at Novell for providing the work-around -- originally
from Novell OES1 -- I had the same issues there...

Without further ado...

If you are having trouble with LUM authentication read TID 3503915.

Realize that the best tip on the page is near the end:

namconfig cache_refresh

It also give you an ldap.conf which actually works, and presents an
intelligent look at the pure-ftp config file with some suggestions for a
configuration that will work as well.

This command flushes out the new LUM users -- to wherever they belong...
wherever that may be...

You may see this authentication issue crop up anywhere you are using LUM
authentication... SAMBA, pureftp etc.

It will show up when you are looking inside the home directory and
possibly creating new user directories -- then you realize that you
cannot set the user id on the permissions -- nor can you assign group
access rights -- you can't see the LUM users and groups!

Once you do the refresh the cache, the LUM enabled users and groups appear.

This solves a multitude of issues.

For those using pure-ftp...

I just left the "base" line commented out. It seems to find the LDAP and
e-directory just fine -- at least on my simple system. Larger systems
will need this sorted out.

Will R
PMC Consulting