I download SLED-10-SP2-x86-DVD1.iso from Novell.

Next, I mount it to /media/iso2 and run zlmload:

dss-cs99la36:# zlmload -P foo -b SLED10-x86-SP2-ZLMLOAD -a sles-10-i586 -d /media/iso2


This is from my workstation:
3N2DHB1:/tmp/zlm # SPident -vv

Summary (using 1152 packages)
Product/ServicePack conflict match update (shipped)
SLE-10-i386 11 0.4% 478 41.5% 19 (2524 18.9%)
- MozillaFirefox 2.0.0.13-1.1 < 1.5.0.4-1.7
- flash-player 9.0.31.0-2.1 < 7.0.63.0-8.1
- imlib2 1.4.0-0.pm.0 < 1.2.1-17.2
- mozilla-nspr 4.7.0-7.4 < 4.6.1-22.2
- mozilla-nspr-devel 4.7.0-7.4 < 4.6.1-22.2
- mozilla-nss 3.11.9-1.2 < 3.11-21.2
- mozilla-nss-devel 3.11.9-1.2 < 3.11-21.2
- netcat 0.7.1-1.i386 < 1.10-883.2.i586
- nmap 2:4.20-1.i386 < 4.00-14.2.i586
- python-elementtree 1.2.6-18 < 1.2.6-18.2
- rpm-python 4.4.2-40 < 4.4.2-43.4
SLE-10-i386-SP1 12 0.6% 984 85.4% 5 (1948 50.5%)
- MozillaFirefox 2.0.0.13-1.1 < 2.0.0.2-2.13
- flash-player 9.0.31.0-2.1 < 9.0.31.0-1.7
- imlib2 1.4.0-0.pm.0 < 1.2.1-17.2
- mozilla-nspr 4.7.0-7.4 < 4.6.4-0.7
- mozilla-nspr-devel 4.7.0-7.4 < 4.6.4-0.7
- mozilla-nss 3.11.9-1.2 < 3.11.4-0.7
- mozilla-nss-devel 3.11.9-1.2 < 3.11.4-0.7
- netcat 0.7.1-1.i386 < 1.10-883.2.i586
- python-elementtree 1.2.6-18 < 1.2.6-18.2
- rpm-python 4.4.2-40 < 4.4.2-43.19
- rug 7.1.1.0-18.23 < 7.2.0.0-0.8
- yast2-samba-server 2.13.11-1.3 < 2.13.22-0.8
Unknown 166 14.4%

Legend for Package Details:
- conflicting package (found < expected)

CONCLUSION: No supported Product/ServicePack found at all!
(at least one conflict has been detected everywhere)

3N2DHB1:/tmp/zlm # cat /etc/novell-release
SUSE Linux Enterprise Desktop 10 (i586)
VERSION = 10
PATCHLEVEL = 1
3N2DHB1:/tmp/zlm # cat /etc/SuSE-release
SUSE Linux Enterprise Desktop 10 (i586)
VERSION = 10
PATCHLEVEL = 1

3N2DHB1:/tmp/zlm # rug ca

Sub'd? | Name | Service
-------+------------------------+--------------------------
Yes | SLED10-x86-SP2-ZLMLOAD | ZENworks Linux Management


3N2DHB1:/tmp/zlm # rug lu
No updates are available.


3N2DHB1:/tmp/zlm # rug pa SLED10-x86.SP2-ZLMLOAD
WARNING: 'SLED10-x86.SP2-ZLMLOAD' is not a valid catalog.
--SNIP--
i | System packages | | vim | 6.4.6-19.4 | i586
--SNIP--

3N2DHB1:/tmp/zlm # rpm -qa | grep vim
vim-6.4.6-19.4

....

When I look at the version of 'vim' in the actual bundle (which is inside the catalog), it lists:
vim 6.4.6-19.12 Vi IMproved sles-10-i586 i586 Upgrade True

----

So, there is an update out there, but for some reason it's not listing when I do a 'rug lu'. I think it has something to do with this message: "SLED10-x86.SP2-ZLMLOAD' is not a valid catalog."

Any ideas?