Trying to use iManager's Clusters role to manage a cluster and get the following file protocol error:

Cannot open the NCS version file on the selected cluster. The Cluster software may not currently be running on this server.

The fact is that the Cluster 1.8 is running on the server where I run iManager 2.6 sp4 too so I don't know where is the problem.

I've found the Cluster 1.8.3 update but it says it is an update to NCS 1.8.2 on NW 6.5 sp5 only - not sp6 installed on my server and not for NCS 1.8.