I have added the smbd, nmbd to the load/unload scripts of an NSS cluster volume and I seem to get my Samba shares in the Windows domain as set in smb.conf on cluster volume.

However, my problem is that the authenication doesn't seem to work.

It will ask for a MS user/pw instead of showing the contents of the dir.

Also, another strange thing is that when the load script calls the smbd, it is told to use the smb.conf on the cluster drive instead of the default location on the /etc/samba/smb.conf. However, iManager -> File Protocols -> Samba -> choose cluster node shows the default smb.conf settings and shares instead of the smb.conf config on the cluster drive. But the new smb.conf seems to create the proper share? I didn't see a step to use symlink to new location of smb.conf, just the cluster load script.

The edir user has been LUM enabled, universal pw, also has a MS object of the same name & pw in a MS domain.

I'm also not quite sure what the sambaproxy user does in this setup.

Any suggestions?

The smb.conf is set as follows:

workgroup = oakville
map to guest = Bad User
usershare allow guests = Yes
bind interfaces only = yes
interfaces =

netbios name = _gissamba
passdb backend = NDS_ldapsam:ldaps://
ldap admin dn = cn=Nloak1-sambaProxy,o=oakville
ldap suffix = o=oakville
ldap passwd sync = on
security = user
encrypt passwords = yes

# NOTE: use sendfile is set to no to support nss filesystem shares.
# To improve performance for other filesystems that support
# sendfile remove this line from the global section and add only
# to share definitions on nss filesystems.
use sendfile = no
server string = 3dsdata
comment = All groups
path = /media/nss/GIS/3dsdata
browseable = yes
read only = No
inherit acls = Yes