Hi Guys,

New notebooks, new imaging dramas (seems to happen every year...). I have tried to compile the drivers as per
Novell Documentation

I have compiled the driver, Atheros(R) AR8121/AR8113 PCI-E) - atl1e.ko, using SLES 10 SP1 as suggested (same kernel as Zen7 imaging) and added it into the initrd file. When I try to load the driver I get the following error:
insmod: error inserting 'modules/atl1e.ko'" -1 Invalid module format.

The original driver is from
ASUSTeK Computer Inc.-Support-
click on that link above, then click on the Drivers tab, then choose Linux as the OS, it will bring you to the page with the linux drivers.

The driver now works in SLES 10 SP1 so I think I have done that part correctly. I am guessing maybe there is also another driver that I need for the chipset or something that Zen7 imaging may need to initialise the chipset or the like.

I have attached the driver if it is of any use to anyone. Just remove the .txt extension

If anyone could help I would be very thankful. We are running IR3a and I have also tried the SLES Sp2 files without luck.