I am in the process of upgrading a site to eDir 8.8 SP2 however I have just found out that they are using ZEN 6.5 and a quick search showes me that zen 6.5 is not supported with 8.8 SP2 Also the server hosting zen holds all the R/W replicas of all the partisions.......!!

What are the implications/recomendations ?

Thanks very much.