Hey All.

I'm having an issue with NAL Terminal Server apps and pass-through
authentication. Here's the details:

1. I've setup a terminal server (Windows 2003 SP2. I've tried both basic
SP2 and SP2+All the updates).
2. I install the Novell Client (4.91 SP4. I've tried LDAP on and off, and
a whole bunch of other different settings).
3. I install ZFDAgent.msi (
4. I create a terminal server application for NAL.
5. When I run this NAL app, it will load the window for terminal services,
but it will stop and ask for a username and password with the Novell Client
Login. It really appears that NOTHING is being passed for credentials.
6. I experiment (manually) with NTSClient.exe and create an INI file that
contains a sample username and password. It launches terminal services AND
successfully logs into the terminal server using the eDirectory credentials
provided in the INI file. It also launches the program I have specified.

I believe the above tests indicate that everything on the terminal server
itself is fine, as I can manually run NTSClient and pass credentials to it
from an INI file. Anytime I run the NAL terminal server app, it seems to
not get or pass any credentials, which results in the user getting a login
dialog on the terminal server. If the user enters there eDirectory
credentials (with LDAP contextless lookup turned on), it will login and run
the app that was specified in the NAL app object.

We used to have the above setup working in a test environment. The only
thing that has really changed on the client end is: XP SP3, Novell Client
4.91 SP4, and ZfdAgent I've searched everywhere I can think of for
possible answers to this, but there appears to be very few finds, except for
people with similar problems who never resolved it (or at least let us know
how it was resolved).

Any suggestions?