This morning I fixed a problem where an NSS volume went off-line. I'm an old NetWare hand (since 2.15) and the transition to linux is giving me fits. I had to do a lot of digging in Google to find the linux commands (nsscon, then nss /poolmaintenance=VOL1) to put the pool into maintenance mode and then run ravsui verify VOL1, then ravsui rebuild VOL1 in order to get the pool rebuilt so the volume would mount.

I'm trying to look at the ravsui log files to see what it did but the syntax example (both in Novell Documentation and the man page) doesn't work.

I tried "ravview -V /var/opt/novell/log/nss/rav/ rtfn VOL1" and I get an error that says "invalid LEVEL format '/var/opt/novell/log/nss/rav/'"

I changed the -V to --verbose=9 and then I get a different error
"FILETYPE /var/opt/novell/log/nss/rav/ is not legal"

If I type "ravview rtfn VOL1 I get the following output:

FileName -
PoolName - VOL1
Servername -
Newest - 1
Verify - 0
Rebuild - 1
Verbose - 4
Directory - /var/opt/novell/log/nss/rav/
List Actions - 0
List Object Details - 0
List Histograms - 0

The rebuild log file /var/opt/novell/log/nss/rav/VOL1_rebuild_48d7ac0b_log.xml will be used.

Rebuild messages
Rebuild start UTC -- 0x48d7ac0b
Invalid Object Node (0x1948da0).
Leaf Pruned, Files Lost (0x1948da0).
Rebuild count -- 1
Orphanage will be named "48d7ac0b.FPD"
Rebuild end UTC -- 0x48d7ad25

Found 6 messages.

Found 8 items that where deleted or truncated.
Ignored 8 expected items.

I've tried various combinations of the options from the Novell Docs (Novell Documentation) but the best I can get is the above output. I'm trying to figure out what the pool rebuild fixed.

The ravview version is as follows:
ravview (NSS) 1.00
Copyright (C) 2005 Novell, Inc.