http://na.blackberry.com/eng/service...ab_tab_upgrade

It says I can upgrade to 4.5 on the device software. When I do help>about it says 4.3, but the upgrade program says I am up-to-date.



Anyone see this?



TIA