I would like to run windows script to extract 7-zip file on XP sp2 but it does not work.

* ZCM10SP1 on Windows 2003 R2 SP2 32bit
* Edirectory onNetWare6.5 SP7
* Clients are all XP SP2

I created a bundle to copy the compressed file, abc.7z to c:\zcm on xp computers and working fine.
I would like to extract the file by script, so I created a script to extract the 7z file and it works fine when I run it manually on XP computer.
However, it does not start or work by ZCM10SP1's bundle and no errors on both Windows Event viewer and ZCC, so I am struggling with this issue.


This is what I did;

1st try:
1. Create Directive Bundle -> Actions -> Run Script -> Define your own script
2. no luck and no errors on both XP event viewer and ZCC

2nd try:
1. Created another bundle to copy the script file to c:\zcm folder on XP computers and this is fine.
2. Create Directive Bundle -> Actions -> Run Script -> Specify a file on managed device to run the copied batch file from c:\zcm\abc.bat
3. no luck no errors on both XP event viewer and ZCC
4. In case, I run the bach file manually and working fine but cannot be run as bundle

3rd try:
1. Create Directive Bundle -> Actions -> Run Script -> Select from this device
2. Run as System but no luck and no errors on both XP event viewer and ZCC
3. Run as Administrator but no luck and no errors on both XP event viewer and ZCC


I was wondering why it does not work, so I created a simple script to create a folder c:\zcm\test as mkdir "C:\zcm\test" but this script does not work by doing the above 3 ways.

It seems Windows script does not on my environment for some reason.

Could you give me some advise, pls?