I'm on an OES2 running on Sles10 sp1. I initially installed the Java
jdk1.6.0_06 using the jdk-6u6-linux-i586.rpm package. I then found out that
my third party software wouldn't run on this platform and needed to have the
jdk1.5.0_15 package instead. So I removed the jdk1.6.0_06 using the Yast
Software management installation summary.

Now when I try to use the jdk-1_5_0_16-linux-i586.rpm package to install
this version I get a message "'Change Summary' '?Apply the following
changes?' 'Install the following additional software' 'jdk-2000:1.6.0_06-fcs
(Package)'" 'Apply' or 'Cancel'. If I apply it installs the jdk1.6.0_06, if
I cancel it won't let me install the jdk-1.5.0_15.

What's up with this? And how can I install the version that I want.