in a previous post I asked why the Web folders functionality that was
really practical under XP doesn't work anymore under Vista. I
investigated a little more an came to the conclusion that it doesn't
work from Windows 2003 and 2008 either. Some precisions:
* Server OES Netware 6.5 SP7, fully patched. The problem was strictly
the same when I tried another server, this time OES2 Linux.
* To avoid any SSL / TLS problem, I worked without encryption
(but,obviously, the TLS is not the problem here).
* I captured the session with Microsoft Network Monitor 3.2 on different
machines, trying to open a web folder named
http://myserver/oneNet/NetStorage/. Summary:
-- from XP, the first Webdav packet is a PROPFIND /oneNet, to which the
server responds HTTP 500, Internal Server Error (you can also obtain
that from a browser: it looses times and should be fixed somewhere). XP
insists on PROPFIND, then tests OPTIONS /oneNet (same result) and,
finally, PROPFIND /oneNet/NetStorage on which the server answers HTTP
401 (auth requested). After authentication, the drives are connected.
-- from either Windows 2003 or 2008 servers or Vista (SP1, 32 bits or 64
bits), the session is different. Windows first tests OPTIONS /, accepted
(HTTP 200). Then PROPFIND /, refused (http 405, method not allowed).
Then PROPFIND /oneNet, which raises http 500 (Internal server error)
and, just after that, Windows closes the connection and raises the note
found error.

I'm not a HTTP or WebDav specialist but I wonder that, maybe, if
NetStorage responded something else that http 500, it may fasten the
connection from XP and allow the connection from Vista. Am I wrong or
what can I do ?

Thanks in advance,

Yves Roy,
University of Poitiers (IAE), France