So if you try to actually use the command-line switches that it SAYS you
can use, it simply doesn't work.

c:\program files\novell\zenworks\bin\ZENworksUninstall.exe

If you do a --help it CLAIMS you can use these switches:

Usage: ZENworksUninstall [Zone Options] [Remove Options] [Display

where options are any of the following:

Zone Options (The uninstall attempts to find reasonable defaults if no
value is supplied)

-z --zone <zone> : Name of this device's zone

-s | --server <server> : Address of primary server

(ex. ( ))

-u | --user <user> : Zone administrative user

-p | --password <pass> : Zone administrator password (This can also be
set in the environment: ZENWORKS_UNINSTALL_PASSWORD)

-g | --guid <guid> : This device's guid

-l | --list-packages <packages> : An ordered, semi-colon delimted list
of packages to uninstall

Remove Options

-c | --local-only : Uninstall the software but do not attempt to remove
the device from the zone

-x | --remove : Remove this device from the zone

-o | --oem : Do not uninstall the ZENworks agent packages

However, I tried with the -c (and also --local-only).

The removal screen does launch, but it does NOT have the "local only"
box checked.

If you try using any of the switches with the -q (--quiet) it just sits
there and nothing happens (because it's basically waiting for you to
enter all the information in even though you've specified the
information in the command-line switches)

The Zone server is toast, so -u and stuff is useless, although I setup
a new 10.1 server and put the agent on ONE machine and tried removing it
with the -u and zone information and it still wouldn't remove.

I ended up having to make a .bat file to uninstall the MSI files
individually in order to remove the darn thing.

Very annoying.
> Display Options
> -q | --quiet : Perform a quiet uninstall (no user interface)
> -h | --help : Display this message and exit