Issue: International characters causing files to not sync to US.

Basic rsync overview:

US: SLES1-, SP1/OES2 running rsyncd 2.6.8 (default installation)
2 EU Locations: NW6.5, SP7 running rsync 2.63 (Netware version)

US rsync.conf:

uid = root
gid = root
log format = %h %o %f %l %b
log file = /var/log/rsyncd.log
transfer logging = true
slp refresh = 300

[UK1]
#path = DATA01:/rsync/uk1
path = /media/nss/DATA01/rsync/uk1
exclude from = /etc/rsync.exclude
read only = false
use chroot = false
transfer logging = true
timeout=3600
hosts allow=10.103.1.10

[DE1]
path = /media/nss/DATA01/rsync/germany
exclude from = /etc/rsync.exclude-de1
read only = false
use chroot = false
transfer logging = true
timeout = 3600
hosts allow=10.104.1.1
#secrets file = /etc/rsyncsecrets.germany

EU rsyncstr.ncf

rsync -rav --volume=VOL1: / DATA2::UK1 (or DE1)

Typical error from rsyncd.log:

2008/10/02 09:44:37 [4573] rsync: stat "/USERS/ ...snip... /Datenbl204tter/Motorola/MC9s12/9S12DP256B-ZIP" (in DE1) failed: Invalid argument (22)

The path and the filename include characters with an umlaut over the "a". There are other international characters scattered throughout the file structure.

Question:

Can I install rsync 3.x on the US side (target) and use the --iconv option to successfully get the files with international characters?

So far as I have been able to tell, there is no --iconv option with rsync versions below 3.x.