From an article I found on

How To Install mod_security/mod_security2 On SuSE Linux Enterprise Server 10 (SLES10)

The Apache module mod_security is a very powerful security module. Combined with predefined rules, you can close many security wholes on your server, opened by bad written php or perl apps.

This is the first paragraph, sorry but you are not impressing me at this point......