This is out of box OES2 install. I made no changes to conf files. Anything I try to access in /srv/www/htdocs directory was being redirected to the welcome pages. Then I removed oes_http.conf link from /etc/apache2/conf.d directory and now I get Access Forbidden when try to access any html or php file I put under /srv/www/htdocs.
This is from default-server.conf:

<Directory "/srv/www/htdocs">
Options None
AllowOverride none
Order allow,deny
Allow from all