I just built up a SLES10 SP1 server w/ OES 2 on it. Im trying to do an update and I get the following errors:

# rug up
Resolving Dependencies...

ERROR: Dependency resolution failed:
Unresolved dependencies:
Updating novell-nwmpk-kmp-default-1.0.2221_2.6.16.46_0.12-2.i586[System packages] to novell-nwmpk-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
Updating nss-kmp-default-4.10.2217_2.6.16.46_0.12-2.i586[System packages] to nss-kmp-default-4.10.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
Updating novell-zapi-kmp-default-1.0.2221_2.6.16.46_0.12-2.i586[System packages] to novell-zapi-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
Establishing novell-zapi-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
There are no installable providers of kernel(default:drivers) == 1166ba124967e036 for novell-zapi-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
Establishing atom:nss-kmp-default-4.10.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
There are no installable providers of kernel(default:drivers) == 1166ba124967e036 for nss-kmp-default-4.10.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
Establishing novell-nwmpk-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]
There are no installable providers of kernel(default:drivers) == 1166ba124967e036 for novell-nwmpk-kmp-default-1.0.2478_2.6.16.54_0.2.11-0.2.1.i586[OES2-Updates]


This is the output of the 'rug up' command. If I try updating through YaST --> Online Update I get similar errors.

-Rob