Hello,

has anybody some experience with the KM Bizhup 40p under Vista with iPrint? The driver for this printer is designed for Win 2000 / Xp and Vista. Running on Win 2000 and XP works just fine... but on Vista i have the following problem:

- Orginal driver loads into the driverstore/broker without problems. Installing the driver/printer on vista always fails with error... Think there is problem in the installation inf-file... (sections for NTx86.6.0...)

- First try was a new generated driver with PDRVGen.exe... A local installation (withou iprint) just works on Vista, installing over iPrint ends with an error (2 (0x00000002) File Not Found) .A trace with ProcessMonitor shows me a seach for c:\*.inf!!! Great, a copy from my new inf-File under C:\ resolves that problem, but this is not realy what i want.... the problem is reported as:

Module: spoolsv.exe
Trace Info: registry.c, line 2621, thread 00000AA0
Routine: FindDriverAndGetInfo - RegOpenKeyEx failed 2
Error: Das System kann die angegebene Datei nicht finden.


- My next try was to modify the inf-File from the orginal driver... (wrote new sections for NTx86.6.0...). Local installations works fine, Uploading the new driver to broker and driverstore works fine, installation over iprint with netware 6.5 SP7 works fine... BUT: Installation (with iprint Client 5.02 / 5.04) over OES2 (LINUX, patched...) just ends with an error:

23.10.2008 - 17:47:17
Module: spoolsv.exe
Trace Info: registry.c, line 2621, thread 00000EF0
Routine: FindDriverAndGetInfo - RegOpenKeyEx failed 2
Error: Das System kann die angegebene Datei nicht finden.


23.10.2008 - 17:48:10
Module: spoolsv.exe
Trace Info: ippmain.c, line 2041, thread 00000EF0
Routine: IppPrintInstaller - UploadPrinterDriverPackageW failed (COM error 2)
Error: Der angegebene Benutzername ist unzulssig.

so the next step was to look for a difference between the driver repository of netware to linux, but there is NO difference!!!

A try with the new iPrint Client 5.08 ends also with an error (unknown string...) but the printer/driver is installed and works fine. A trace within ProcessMonitor reports an error on creation from two files -> C:\$TOPS and C:\FI_UNKNOWN. The error is also reported as:

Module: spoolsv.exe
Trace Info: registry.c, line 2621, thread 00000EF0
Routine: FindDriverAndGetInfo - RegOpenKeyEx failed 2


So it seems to be very interesting what line 2621 does within the registry.c module!? Any ideas / comments?

regards,

Lars