We have problems with inaccessible DFS junctions

We have on our servers:

eDirectory: 8.7.3.9 (NW6.5SP7) with Zen7

On our clients:

WinXP SP2
NwClient 4.91 SPP4
Zenworks client: 7.0.1.4


I have made a ZEN application object for a application running from a DFS Junction.
When I login to my pc and click on the application I get the message:
************************************************** ************************************
Could not launch portscan.testou (using k:\data\apps\portscan.exe) (id=31)
A device attached to the system is not functioning.
************************************************** ************************************

De apps folder is a junction to another volume.

When I go to the k:\data\apps folder I get:
************************************************** ************************************************** ****************
Windows cannot read from this disk. The disk might be corrupted, or it could be using a format that is not compatible with Windows
************************************************** ************************************************** ****************

When I browse directly to the volume where the junction is pointing to, I can start my application.

When I look to the rights on k:\data\apps and de volume where the junction is pointing the are OK.


This looks the same like the bug in older nwclients:

(10090516: Fixes included in the Novell Client v4.9 SP2 for Windows NT/2000/XP)

When attempting to go to a DFS Junction, Windows XP returns with the following error: "Disk is not formatted" "Windows cannot read from this disk. The disk might be corrupted, or it could be using a format that is not compatible with Windows."


Have anyone any idea what causing this problem ?

Cheers,
PTR