I have a Brocade Silkworm Fibre Channel/Adaptec SAN. I have a four server NW-OES Cluster running off of this san, consisting of three NSS Pools that run GroupWise, Zenworks and Print and File services. The cluster loads and all volumes mount just fine. But I started getting errors a few weeks ago of this variety:

NSS-2.70-5008: Volume CS2/CLS_DATA had an error
(20012(beastTree.c[510])) at block 48871432(file block -48871432)(ZID 1).

I ran rebuild on all three pools and the errors stopped.

Now when I try to restore Zenworks images from the Zen pool they fail and the server usually abends, Also I cannot run installation packages that contain cab files from the data volume. For example I had an Office 2007 install point on the Data volume and now it does not work. I downloaded a fresh copy of it, ran it from a local hard drive and the install worked fine. I then copied up to the SAN cluster volume and the install does not work.

Is it some kind of compression problem?

Any help that will point me in the right direction would be great.