netware 65sp5

having issues with netstorage since reboot.. i think the reason for this is that we had some certificates a while back that were expired and we ran pkidiag to fix them and this was first reboot since then... having issues with netstorage getting 503 error when trying to upload files...

checked certificates in console one.. when i look at these certificates

SSL CertificateDNS
SSL CertificateIP

all the trusted root certs are good but some of the public key certs are expired...

pkidiag shows no errors when i run it...but tomcat was getting errors when loading...i ran tckeygen and unoladed and reloaded apache and tomcat errors but i'm assuming the public key certs being expired is the reason that netstorage will not work...what's the best way to replace the public key certs that are expired or expiring.. i have found alot of varying information out in google world and i want to know the best way to go about i understand it the trusted root and pk certs are suppose to work as a pair so it seems that the pk could be created or updated from the trusted root i thinking about this all wrong???