Hi,

We have been using Novell Bordermanager 3.x radius for several years
now upgrading the OS and BorderManager along the way.

Our current configuration is NetWare 6 SP5 and Bordermanager 3.6
(authentication services only). In the past year or more we have been
having problems with radius authentication. The problems were
intermittent and usually disappeared after unloading and reloading
radius. They have become much more troublesome since SP5.

We use radius in a fashion similar to an ISP. We have a Cisco 2511
router with 8 dialup modems. Users dial the access numbers and the
Cisco router authenticates them with radius running on the NW6 server.
We use NDS passwords for authentication and a single context is
specified for username lookup. We don't use the login policy object.
The purpose of the setup is to allow users internet access. The Cisco
router does not do any actual routing but simply acts as an access
server that authenticates users.

The setup worked without problems for several years. Then for no
apparent reason we started having problems. The first problem was that
authentication would take so long that that the line would be dropped
and a minute later the user would be authenticated. I applied the
BMAS36_01 patch that solved that particular problem. we had some other
problems that were solved by different TIDs.

This year we started having problems with users not authenticating
(not even delayed authentication would happen). If the user dialled
the access server several times they could eventually authenticate.
The problem was intermittent and not limited to specific users. We
upgraded to SP5 about a week ago and a new problem has crept up after
the four or five days. The authentication problem remains but now
regardless of who authenticates the radius server displays the name of
the same user for 5-20 times. Specifically user1 authenticates and the
radius server (console screen) indicates user1 has authenticated. Then
user2 authenticates and the radius server indicates user1 has
authenticated. This goes on for several users and then the radius
server start displaying a different username as being authenticated
for all users and so on.

I have run unattended dsrepair (0 errors). I have gone through every
TID I can find as well as through the forums and I cannot find a
solution.

I would greatly appreciate advice from anyone who has experienced
anything similar.

Thanks in advance.

Mehmet Boyaci