On my machine ( an old CL380 clusterbox ) i am attempting to install SLES10SP1 and OES2 ..

So far nothing special .. but

The scsi driver detects the CR3500's ( sym53c8xx ) but not hte array of shared storage behind it ...

i know it's an old box, so there would be issues ... so.. has anyone attempted my setting ?

Code:
LX-CL-N1:~ # modprobe sym53c8xx hostid=6 verb=1 | tail -f /var/log/messages
Nov 17 20:13:57 LX-CL-N1 kernel: sym1: detaching ...
Nov 17 20:13:57 LX-CL-N1 kernel: sym1: resetting chip
Nov 17 20:13:57 LX-CL-N1 kernel: ACPI: PCI interrupt for device 0000:03:04.1 disabled
Nov 17 20:13:57 LX-CL-N1 kernel: sym0: detaching ...
Nov 17 20:13:57 LX-CL-N1 kernel: sym0: resetting chip
Nov 17 20:13:57 LX-CL-N1 kernel: ACPI: PCI interrupt for device 0000:03:04.0 disabled
Nov 17 20:14:53 LX-CL-N1 kernel: ACPI: PCI Interrupt 0000:03:04.0[A] -> GSI 27 (level, low) -> IRQ 185
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: <896> rev 0x7 at pci 0000:03:04.0 irq 185
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: No NVRAM, ID 6, Fast-40, LVD, parity checking
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: open drain IRQ line driver, using on-chip SRAM
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: using LOAD/STORE-based firmware.
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: handling phase mismatch from SCRIPTS.
Nov 17 20:14:53 LX-CL-N1 kernel: sym0: SCSI BUS has been reset.
Nov 17 20:14:53 LX-CL-N1 kernel: scsi2 : sym-2.2.3
Nov 17 20:14:56 LX-CL-N1 kernel:   Vendor: Compaq    Model: CR3500            Rev: x2r-
Nov 17 20:14:56 LX-CL-N1 kernel:   Type:   RAID                               ANSI SCSI revision: 02
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: tagged command queuing enabled, command queue depth 16.
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: Beginning Domain Validation
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: asynchronous
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: wide asynchronous
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: FAST-20 WIDE SCSI 40.0 MB/s ST (50 ns, offset 15)
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: Domain Validation skipping write tests
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:2: Ending Domain Validation
Nov 17 20:14:56 LX-CL-N1 kernel:  2:0:2:0: Attached scsi generic sg0 type 12
Nov 17 20:14:56 LX-CL-N1 kernel:   Vendor: Compaq    Model: CR3500            Rev: x2r-
Nov 17 20:14:56 LX-CL-N1 kernel:   Type:   RAID                               ANSI SCSI revision: 02
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: tagged command queuing enabled, command queue depth 16.
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: Beginning Domain Validation
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: asynchronous
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: wide asynchronous
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: FAST-20 WIDE SCSI 40.0 MB/s ST (50 ns, offset 15)
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: Domain Validation skipping write tests
Nov 17 20:14:56 LX-CL-N1 kernel:  target2:0:3: Ending Domain Validation
Nov 17 20:14:56 LX-CL-N1 kernel:  2:0:3:0: Attached scsi generic sg1 type 12
Nov 17 20:15:00 LX-CL-N1 kernel: ACPI: PCI Interrupt 0000:03:04.1[B] -> GSI 26 (level, low) -> IRQ 193
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: <896> rev 0x7 at pci 0000:03:04.1 irq 193
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: No NVRAM, ID 6, Fast-40, LVD, parity checking
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: open drain IRQ line driver, using on-chip SRAM
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: using LOAD/STORE-based firmware.
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: handling phase mismatch from SCRIPTS.
Nov 17 20:15:00 LX-CL-N1 kernel: sym1: SCSI BUS has been reset.
Nov 17 20:15:00 LX-CL-N1 kernel: scsi3 : sym-2.2.3
the box has latest firmware i could find, bus as it's an old machine it isn't really new ...
it should have something to do with scanning all lun's .. so in that attempt i've run a script :

Code:
LX-CL-N1:~ # ./scan-scsi.sh -v
Host adapter 2 (sym53c8xx) found.
Host adapter 3 (sym53c8xx) found.
Unknown option -v !
Scanning SCSI subsystem for new devices
Scanning host 2 channels 0 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 2 0 2 0 ...
OLD: Host: scsi2 Channel: 00 Id: 02 Lun: 00
      Vendor: Compaq   Model: CR3500           Rev: x2r-
      Type:   RAID                             ANSI SCSI revision: 02
Report Luns command not supported (support mandatory in SPC-3)
Scanning for device 2 0 2 0 ...
OLD: Host: scsi2 Channel: 00 Id: 02 Lun: 00
      Vendor: Compaq   Model: CR3500           Rev: x2r-
      Type:   RAID                             ANSI SCSI revision: 02
Scanning for device 2 0 3 0 ...
OLD: Host: scsi2 Channel: 00 Id: 03 Lun: 00
      Vendor: Compaq   Model: CR3500           Rev: x2r-
      Type:   RAID                             ANSI SCSI revision: 02
Report Luns command not supported (support mandatory in SPC-3)
Scanning for device 2 0 3 0 ...
OLD: Host: scsi2 Channel: 00 Id: 03 Lun: 00
      Vendor: Compaq   Model: CR3500           Rev: x2r-
      Type:   RAID                             ANSI SCSI revision: 02
Scanning host 3 channels 0 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
0 new device(s) found.
0 device(s) removed.
i have tried writing to the email addy in the documentation of hte sym53c8xx module/driver but it's a dead mailbox .. so last resort is here ...